Discuz!应用中心安装模板提示版本号不匹配的解决方法

Tag:

推荐: 西部数码网站管理助手开启自定义伪静态教程
西部数码网站管理助手开启自定义伪静态教程

?有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?经过我们分析发现是因为X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的时候发布,而且之前的机制里一直是即使版本号不同,用户依然可以强制安装,但是,从X3.1后期开始,官方自己把自己的规矩改了,用户没有办法强制安装了,很多作者也没有在意这点,而且应用中心模板的审核与发布、更新的周期更让作者们苦等。Sit知源库资源网(www.wxiis.com)最新最全的亚博体育登录入口分享下载平台

下面我们以discuz! X3的qing模板安装在X3.2上为例子讲解。
首先说的是错误提示图,如下图所示,官方发布的升级版版本号还是X2.5的,不过这不影响我们演示:
1-151231100042B1.jpg

我们打开template/qing(其他模板为其他模板的目录)/discuz_style_qing.xml文件,在里面找到X2.5,
如果错误图提示为什么版本就搜什么版本,通常能搜索到至少两处
修改成自己的版本然后保存,重新在后台,界面,风格设置处安装模板即可。
?

分享: discuz门户diy实现翻页功能的方法
1、打开 \source\class\block\portal\block_article.php 文件找到function getdata($style, $parameter)修改为function getdata($style, $parameter, $bid)找到$query = D

作者:ziyuanku/ 所属分类:CMS/ 更新时间:2017-07-11
最新评论:发布评论
共 条评论

用户名: ?? 密码:?? 验证码: ???? ? 匿名评论
相关CMS教程
    无相关信息
? ? 2016 ? www.wxiis.com知源库资源网
收藏&分享